安全公告详情

NS-SA-2019-0046

2019-07-17 14:56:29

简介

important: ghostscript/corosync security update

严重级别

important

主题

An update for ghostscript/corosync is now available for NewStart CGSL MAIN 5.04/CGSL CORE 5.04.
NewStart Security has rated this update as having a security impact of important. A Common Vunlnerability Scoring System(CVSS)base score, which gives a detailed severity rating, is available for each vulnerability from the CVElink(s) in the References section.

详细描述

ghostscript: Ghostscript is a set of software that provides a PostScript interpreter, a set of C procedures (the Ghostscript library, which implements the graphics capabilities in the PostScript language) and an interpreter for Portable Document Format (PDF) files. Ghostscript translates PostScript code into many common, bitmapped formats, like those understood by your printer or screen. Ghostscript is normally used to display PostScript files and to print PostScript files to non-PostScript printers. If you need to display PostScript files or print them to non-PostScript printers, you should install ghostscript. If you install ghostscript, you also need to install the ghostscript-fonts package.
corosync: This package contains the Corosync Cluster Engine Executive, several default APIs and libraries, default configuration files, and an init script.


Security Fix(es):
ghostscript: An issue was discovered in Artifex Ghostscript before 9.26. LockSafetyParams is not checked correctly if another device is used.(CVE-2018-19409)
ghostscript: It was discovered that the ghostscript .tempfile function did not properly handle file permissions. An attacker could possibly exploit this to exploit this to bypass the -dSAFER protection and delete files or disclose their content via a specially crafted PostScript document.(CVE-2018-15908)
ghostscript: An issue was discovered in Artifex Ghostscript before 9.25. Incorrect "restoration of privilege" checking when running out of stack during exception handling could be used by attackers able to supply crafted PostScript to execute code using the "pipe" instruction. This is due to an incomplete fix for CVE-2018-16509.(CVE-2018-16802)
ghostscript: It was discovered that the ghostscript device cleanup did not properly handle devices replaced with a null device. An attacker could possibly exploit this to bypass the -dSAFER protection and crash ghostscript or, possibly, execute arbitrary code in the ghostscript context via a specially crafted PostScript document.(CVE-2018-16541)
ghostscript: It was discovered that ghostscript did not properly verify the key used in aesdecode. An attacker could possibly exploit this to bypass the -dSAFER protection and crash ghostscript or, possibly, execute arbitrary code in the ghostscript context via a specially crafted PostScript document.(CVE-2018-15911)
ghostscript: It was discovered that the ghostscript did not properly restrict access to files open prior to enabling the -dSAFER mode. An attacker could possibly exploit this to bypass the -dSAFER protection and disclose the content of affected files via a specially crafted PostScript document.(CVE-2018-16539)
ghostscript: Artifex Ghostscript before 9.25 allowed a user-writable error exception table, which could be used by remote attackers able to supply crafted PostScript to potentially overwrite or replace error handlers to inject code.(CVE-2018-17183)
ghostscript: Artifex Ghostscript 9.25 and earlier allows attackers to bypass a sandbox protection mechanism via vectors involving errorhandler setup. NOTE: this issue exists because of an incomplete fix for CVE-2018-17183.(CVE-2018-17961)
ghostscript: Artifex Ghostscript allows attackers to bypass a sandbox protection mechanism by leveraging exposure of system operators in the saved execution stack in an error object.(CVE-2018-18073)
ghostscript: Artifex Ghostscript 9.25 and earlier allows attackers to bypass a sandbox protection mechanism via vectors involving the 1Policy operator.(CVE-2018-18284)
ghostscript: It was found that RHSA-2018:2918 did not fully fix CVE-2018-16509. An attacker could possibly exploit another variant of the flaw and bypass the -dSAFER protection to, for example, execute arbitrary shell commands via a specially crafted PostScript document.(CVE-2018-16863)
ghostscript: In Artifex Ghostscript through 9.25, the setpattern operator did not properly validate certain types. A specially crafted PostScript document could exploit this to crash Ghostscript or, possibly, execute arbitrary code in the context of the Ghostscript process. This is a type confusion issue because of failure to check whether the Implementation of a pattern dictionary was a structure type.(CVE-2018-19134)
ghostscript: It was discovered that the ghostscript .shfill operator did not properly validate certain types. An attacker could possibly exploit this to bypass the -dSAFER protection and crash ghostscript or, possibly, execute arbitrary code in the ghostscript context via a specially crafted PostScript document.(CVE-2018-15909)
ghostscript: It was discovered that the ghostscript .type operator did not properly validate its operands. A specially crafted PostScript document could exploit this to crash ghostscript or, possibly, execute arbitrary code in the context of the ghostscript process.(CVE-2018-16511)
ghostscript: bugfix
corosync: An integer overflow leading to an out-of-bound read was found in authenticate_nss_2_3() in Corosync. An attacker could craft a malicious packet that would lead to a denial of service.(CVE-2018-1084)
corosync: bugfix


Solution:
For details on how to apply this update, which includes the changes described in this advisory, refer to:
http://security.gd-linux.com/how_to_apply_patch.html
Remember the build tag is 5.04.F8.

影响组件

  • ghostscript
  • corosync

影响产品

  • CGSL MAIN 5.04
  • CGSL CORE 5.04

更新包

{"fix":[{"product":"CGSL MAIN 5.04","pkgs":[{"binary":["ghostscript-9.07-31.el7_6.6.x86_64.rpm","ghostscript-cups-9.07-31.el7_6.6.x86_64.rpm","ghostscript-debuginfo-9.07-31.el7_6.6.x86_64.rpm","ghostscript-devel-9.07-31.el7_6.6.x86_64.rpm","ghostscript-doc-9.07-31.el7_6.6.noarch.rpm","ghostscript-gtk-9.07-31.el7_6.6.x86_64.rpm"],"source":"ghostscript-9.07-31.el7_6.6.src.rpm"},{"binary":["corosync-2.4.3-4.el7.x86_64.rpm","corosync-debuginfo-2.4.3-4.el7.x86_64.rpm","corosync-qdevice-2.4.3-4.el7.x86_64.rpm","corosync-qnetd-2.4.3-4.el7.x86_64.rpm","corosynclib-2.4.3-4.el7.x86_64.rpm","corosynclib-devel-2.4.3-4.el7.x86_64.rpm"],"source":"corosync-2.4.3-4.el7.src.rpm"}]},{"product":"CGSL CORE 5.04","pkgs":[{"binary":["ghostscript-9.07-31.el7_6.6.x86_64.rpm","ghostscript-cups-9.07-31.el7_6.6.x86_64.rpm","ghostscript-debuginfo-9.07-31.el7_6.6.x86_64.rpm","ghostscript-devel-9.07-31.el7_6.6.x86_64.rpm","ghostscript-doc-9.07-31.el7_6.6.noarch.rpm","ghostscript-gtk-9.07-31.el7_6.6.x86_64.rpm"],"source":"ghostscript-9.07-31.el7_6.6.src.rpm"},{"binary":["corosync-2.4.3-4.el7.x86_64.rpm","corosync-debuginfo-2.4.3-4.el7.x86_64.rpm","corosync-qdevice-2.4.3-4.el7.x86_64.rpm","corosync-qnetd-2.4.3-4.el7.x86_64.rpm","corosynclib-2.4.3-4.el7.x86_64.rpm","corosynclib-devel-2.4.3-4.el7.x86_64.rpm"],"source":"corosync-2.4.3-4.el7.src.rpm"}]}]}

CVE

参考