安全公告详情

NS-SA-2020-0011

2020-03-04 10:15:11

简介

critical: firefox/apache-commons-beanutils security update

严重级别

critical

主题

An update for firefox/apache-commons-beanutils is now available for NewStart CGSL MAIN 5.04/CGSL CORE 5.04.
NewStart Security has rated this update as having a security impact of critical. A Common Vunlnerability Scoring System(CVSS)base score, which gives a detailed severity rating, is available for each vulnerability from the CVElink(s) in the References section.

详细描述

firefox: Mozilla Firefox is an open-source web browser, designed for standards compliance, performance and portability.
apache-commons-beanutils: The scope of this package is to create a package of Java utility methods for accessing and modifying the properties of arbitrary JavaBeans. No dependencies outside of the JDK are required, so the use of this package is very lightweight.


Security Fix(es):
firefox: When pasting a <style> tag from the clipboard into a rich text editor, the CSS sanitizer does not escape < and > characters. Because the resulting string is pasted directly into the text node of the element this does not result in a direct injection into the webpage; however, if a webpage subsequently copies the node's innerHTML, assigning it to another innerHTML, this would result in an XSS vulnerability. Two WYSIWYG editors were identified with this behavior, more may exist. This vulnerability affects Firefox ESR < 68.4 and Firefox < 72.(CVE-2019-17022)
firefox: When pasting a <style> tag from the clipboard into a rich text editor, the CSS sanitizer incorrectly rewrites a @namespace rule. This could allow for injection into certain types of websites resulting in data exfiltration. This vulnerability affects Firefox ESR < 68.4 and Firefox < 72.(CVE-2019-17016)
firefox: Due to a missing case handling object types, a type confusion vulnerability could occur, resulting in a crash. We presume that with enough effort that it could be exploited to run arbitrary code. This vulnerability affects Firefox ESR < 68.4 and Firefox < 72.(CVE-2019-17017)
firefox: Mozilla developers reported memory safety bugs present in Firefox 71 and Firefox ESR 68.3. Some of these bugs showed evidence of memory corruption and we presume that with enough effort some of these could have been exploited to run arbitrary code. This vulnerability affects Firefox ESR < 68.4 and Firefox < 72.(CVE-2019-17024)
firefox: Incorrect alias information in IonMonkey JIT compiler for setting array elements could lead to a type confusion. We are aware of targeted attacks in the wild abusing this flaw. This vulnerability affects Firefox ESR < 68.4.1, Thunderbird < 68.4.1, and Firefox < 72.0.1.(CVE-2019-17026)
firefox: bugfix
apache-commons-beanutils: In Apache Commons Beanutils 1.9.2, a special BeanIntrospector class was added which allows suppressing the ability for an attacker to access the classloader via the class property available on all Java objects. We, however were not using this by default characteristic of the PropertyUtilsBean.(CVE-2019-10086)
apache-commons-beanutils: bugfix


Solution:
For details on how to apply this update, which includes the changes described in this advisory, refer to:
http://security.gd-linux.com/how_to_apply_patch.html
Remember the build tag is 5.04.F22.

影响组件

  • firefox
  • apache-commons-beanutils

影响产品

  • CGSL MAIN 5.04
  • CGSL CORE 5.04

更新包

{"fix":[{"product":"CGSL MAIN 5.04","pkgs":[{"binary":["firefox-68.4.1-1.el7.centos.x86_64.rpm","firefox-debuginfo-68.4.1-1.el7.centos.x86_64.rpm"],"source":"firefox-68.4.1-1.el7.centos.src.rpm"},{"binary":["apache-commons-beanutils-1.8.3-15.el7_7.noarch.rpm","apache-commons-beanutils-javadoc-1.8.3-15.el7_7.noarch.rpm"],"source":"apache-commons-beanutils-1.8.3-15.el7_7.src.rpm"}]},{"product":"CGSL CORE 5.04","pkgs":[{"binary":["firefox-68.4.1-1.el7.centos.x86_64.rpm","firefox-debuginfo-68.4.1-1.el7.centos.x86_64.rpm"],"source":"firefox-68.4.1-1.el7.centos.src.rpm"},{"binary":["apache-commons-beanutils-1.8.3-15.el7_7.noarch.rpm","apache-commons-beanutils-javadoc-1.8.3-15.el7_7.noarch.rpm"],"source":"apache-commons-beanutils-1.8.3-15.el7_7.src.rpm"}]}]}

CVE

参考