安全公告详情

NS-SA-2019-0029

2019-07-17 14:55:39

简介

important: ntp/patch security update

严重级别

important

主题

An update for ntp/patch is now available for NewStart CGSL MAIN 5.04/CGSL CORE 5.04.
NewStart Security has rated this update as having a security impact of important. A Common Vunlnerability Scoring System(CVSS)base score, which gives a detailed severity rating, is available for each vulnerability from the CVElink(s) in the References section.

详细描述

ntp: The Network Time Protocol (NTP) is used to synchronize a computer's time with another reference time source. This package includes ntpd (a daemon which continuously adjusts system time) and utilities used to query and configure the ntpd daemon. Perl scripts ntp-wait and ntptrace are in the ntp-perl package, ntpdate is in the ntpdate package and sntp is in the sntp package. The documentation is in the ntp-doc package.
patch: The patch program applies diff files to originals. The diff command is used to compare an original to a changed file. Diff lists the changes made to the file. A person who has the original file can then use the patch command with the diff file to add the changes to their original file (patching the file). Patch should be installed because it is a common way of upgrading applications.


Security Fix(es):
ntp: A vulnerability was discovered in the NTP server's parsing of configuration directives. A remote, authenticated attacker could cause ntpd to crash by sending a crafted message.(CVE-2017-6463)
ntp: A vulnerability was discovered in the NTP server's parsing of configuration directives. A remote, authenticated attacker could cause ntpd to crash by sending a crafted message.(CVE-2017-6464)
ntp: A vulnerability was found in NTP, in the parsing of packets from the /dev/datum device. A malicious device could send crafted messages, causing ntpd to crash.(CVE-2017-6462)
ntp: bugfix
patch: GNU Patch version 2.7.6 contains an input validation vulnerability when processing patch files, specifically the EDITOR_PROGRAM invocation (using ed) can result in code execution. This attack appear to be exploitable via a patch file processed via the patch utility. This is similar to FreeBSD's CVE-2015-1418 however although they share a common ancestry the code bases have diverged over time.(CVE-2018-1000156)
patch: bugfix


Solution:
For details on how to apply this update, which includes the changes described in this advisory, refer to:
http://security.gd-linux.com/how_to_apply_patch.html
Remember the build tag is 5.04.F6.

影响组件

  • ntp
  • patch

影响产品

  • CGSL MAIN 5.04
  • CGSL CORE 5.04

更新包

{"fix":[{"product":"CGSL MAIN 5.04","pkgs":[{"binary":["sntp-4.2.6p5-28.el7.centos.x86_64.rpm","ntp-4.2.6p5-28.el7.centos.x86_64.rpm","ntp-debuginfo-4.2.6p5-28.el7.centos.x86_64.rpm","ntp-doc-4.2.6p5-28.el7.centos.noarch.rpm","ntp-perl-4.2.6p5-28.el7.centos.noarch.rpm","ntpdate-4.2.6p5-28.el7.centos.x86_64.rpm"],"source":"ntp-4.2.6p5-28.el7.centos.src.rpm"},{"binary":["patch-2.7.1-10.el7_5.x86_64.rpm","patch-debuginfo-2.7.1-10.el7_5.x86_64.rpm"],"source":"patch-2.7.1-10.el7_5.src.rpm"}]},{"product":"CGSL CORE 5.04","pkgs":[{"binary":["sntp-4.2.6p5-28.el7.centos.x86_64.rpm","ntp-4.2.6p5-28.el7.centos.x86_64.rpm","ntp-debuginfo-4.2.6p5-28.el7.centos.x86_64.rpm","ntp-doc-4.2.6p5-28.el7.centos.noarch.rpm","ntp-perl-4.2.6p5-28.el7.centos.noarch.rpm","ntpdate-4.2.6p5-28.el7.centos.x86_64.rpm"],"source":"ntp-4.2.6p5-28.el7.centos.src.rpm"},{"binary":["patch-2.7.1-10.el7_5.x86_64.rpm","patch-debuginfo-2.7.1-10.el7_5.x86_64.rpm"],"source":"patch-2.7.1-10.el7_5.src.rpm"}]}]}

CVE

参考