安全公告详情

NS-SA-2022-0041

2022-05-08 20:18:47

简介

important: bind/firefox security update

严重级别

important

主题

An update for bind/firefox is now available for NewStart CGSL MAIN 5.05/CGSL CORE 5.05.
NewStart Security has rated this update as having a security impact of important. A Common Vunlnerability Scoring System(CVSS)base score, which gives a detailed severity rating, is available for each vulnerability from the CVElink(s) in the References section.

详细描述

bind: This package contains a tree of files which can be used as a chroot(2) jail for the named(8) program from the BIND package. Based on the code from Jan "Yenya" Kasprzak
firefox: Mozilla Firefox is an open-source web browser, designed for standards compliance, performance and portability.


Security Fix(es):
bind: Incremental zone transfers (IXFR) provide a way of transferring changed portion(s) of a zone between servers. An IXFR stream containing SOA records with an owner name other than the transferred zone's apex may cause the receiving named server to inadvertently remove the SOA record for the zone in question from the zone database. This leads to an assertion failure when the next SOA refresh query for that zone is made.(CVE-2021-25214)
bind: bugfix
firefox: A malicious webpage could have triggered a use-after-free, memory corruption, and a potentially exploitable crash. *This bug could only be triggered when accessibility was enabled.*. This vulnerability affects Thunderbird < 78.12, Firefox ESR < 78.12, and Firefox < 90.(CVE-2021-29970)
firefox: Mozilla developers reported memory safety bugs present in code shared between Firefox and Thunderbird. Some of these bugs showed evidence of memory corruption and we presume that with enough effort some of these could have been exploited to run arbitrary code. This vulnerability affects Thunderbird < 78.12, Firefox ESR < 78.12, and Firefox < 90.(CVE-2021-29976)
firefox: Out of bounds write in ANGLE in Google Chrome prior to 91.0.4472.101 allowed a remote attacker to potentially perform out of bounds memory access via a crafted HTML page.(CVE-2021-30547)
firefox: A suspected race condition when calling getaddrinfo led to memory corruption and a potentially exploitable crash. *Note: This issue only affected Linux operating systems. Other operating systems are unaffected.* This vulnerability affects Thunderbird < 78.13, Thunderbird < 91, Firefox ESR < 78.13, and Firefox < 91.(CVE-2021-29986)
firefox: Firefox incorrectly treated an inline list-item element as a block element, resulting in an out of bounds read or memory corruption, and a potentially exploitable crash. This vulnerability affects Thunderbird < 78.13, Thunderbird < 91, Firefox ESR < 78.13, and Firefox < 91.(CVE-2021-29988)
firefox: Instruction reordering resulted in a sequence of instructions that would cause an object to be incorrectly considered during garbage collection. This led to memory corruption and a potentially exploitable crash. This vulnerability affects Thunderbird < 78.13, Thunderbird < 91, Firefox ESR < 78.13, and Firefox < 91.(CVE-2021-29984)
firefox: Uninitialized memory in a canvas object could have caused an incorrect free() leading to memory corruption and a potentially exploitable crash. This vulnerability affects Thunderbird < 78.13, Thunderbird < 91, Firefox ESR < 78.13, and Firefox < 91.(CVE-2021-29980)
firefox: A use-after-free vulnerability in media channels could have led to memory corruption and a potentially exploitable crash. This vulnerability affects Thunderbird < 78.13, Thunderbird < 91, Firefox ESR < 78.13, and Firefox < 91.(CVE-2021-29985)
firefox: Mozilla developers reported memory safety bugs present in Firefox 90 and Firefox ESR 78.12. Some of these bugs showed evidence of memory corruption and we presume that with enough effort some of these could have been exploited to run arbitrary code. This vulnerability affects Thunderbird < 78.13, Firefox ESR < 78.13, and Firefox < 91.(CVE-2021-29989)
firefox: Mozilla developers reported memory safety bugs present in Firefox 91 and Firefox ESR 78.13. Some of these bugs showed evidence of memory corruption and we presume that with enough effort some of these could have been exploited to run arbitrary code. This vulnerability affects Firefox ESR < 78.14, Thunderbird < 78.14, and Firefox < 92.(CVE-2021-38493)
firefox: bugfix


Solution:
For details on how to apply this update, which includes the changes described in this advisory, refer to:
http://security.gd-linux.com/how_to_apply_patch.html
Remember the build tag is 5.05.F14B4.

影响组件

  • bind
  • firefox

影响产品

  • CGSL MAIN 5.05
  • CGSL CORE 5.05

更新包

{"fix":[{"product":"CGSL MAIN 5.05","pkgs":[{"binary":["bind-pkcs11-devel-9.11.4-26.P2.el7_9.7.x86_64.rpm","bind-libs-lite-9.11.4-26.P2.el7_9.7.x86_64.rpm","bind-export-libs-9.11.4-26.P2.el7_9.7.x86_64.rpm","bind-devel-9.11.4-26.P2.el7_9.7.x86_64.rpm","bind-libs-9.11.4-26.P2.el7_9.7.x86_64.rpm","bind-pkcs11-utils-9.11.4-26.P2.el7_9.7.x86_64.rpm","bind-lite-devel-9.11.4-26.P2.el7_9.7.x86_64.rpm","bind-sdb-9.11.4-26.P2.el7_9.7.x86_64.rpm","bind-pkcs11-9.11.4-26.P2.el7_9.7.x86_64.rpm","bind-utils-9.11.4-26.P2.el7_9.7.x86_64.rpm","bind-pkcs11-libs-9.11.4-26.P2.el7_9.7.x86_64.rpm","bind-chroot-9.11.4-26.P2.el7_9.7.x86_64.rpm","bind-license-9.11.4-26.P2.el7_9.7.noarch.rpm","bind-debuginfo-9.11.4-26.P2.el7_9.7.x86_64.rpm","bind-export-devel-9.11.4-26.P2.el7_9.7.x86_64.rpm","bind-9.11.4-26.P2.el7_9.7.x86_64.rpm","bind-sdb-chroot-9.11.4-26.P2.el7_9.7.x86_64.rpm"],"source":"bind-9.11.4-26.P2.el7_9.7.src.rpm"},{"binary":["firefox-debuginfo-78.14.0-1.el7.centos.x86_64.rpm","firefox-78.14.0-1.el7.centos.x86_64.rpm"],"source":"firefox-78.14.0-1.el7.centos.src.rpm"}]},{"product":"CGSL CORE 5.05","pkgs":[{"binary":["bind-pkcs11-devel-9.11.4-26.P2.el7_9.7.x86_64.rpm","bind-libs-lite-9.11.4-26.P2.el7_9.7.x86_64.rpm","bind-export-libs-9.11.4-26.P2.el7_9.7.x86_64.rpm","bind-devel-9.11.4-26.P2.el7_9.7.x86_64.rpm","bind-libs-9.11.4-26.P2.el7_9.7.x86_64.rpm","bind-pkcs11-utils-9.11.4-26.P2.el7_9.7.x86_64.rpm","bind-lite-devel-9.11.4-26.P2.el7_9.7.x86_64.rpm","bind-sdb-9.11.4-26.P2.el7_9.7.x86_64.rpm","bind-pkcs11-9.11.4-26.P2.el7_9.7.x86_64.rpm","bind-utils-9.11.4-26.P2.el7_9.7.x86_64.rpm","bind-pkcs11-libs-9.11.4-26.P2.el7_9.7.x86_64.rpm","bind-chroot-9.11.4-26.P2.el7_9.7.x86_64.rpm","bind-license-9.11.4-26.P2.el7_9.7.noarch.rpm","bind-debuginfo-9.11.4-26.P2.el7_9.7.x86_64.rpm","bind-export-devel-9.11.4-26.P2.el7_9.7.x86_64.rpm","bind-9.11.4-26.P2.el7_9.7.x86_64.rpm","bind-sdb-chroot-9.11.4-26.P2.el7_9.7.x86_64.rpm"],"source":"bind-9.11.4-26.P2.el7_9.7.src.rpm"},{"binary":["firefox-debuginfo-78.14.0-1.el7.centos.x86_64.rpm","firefox-78.14.0-1.el7.centos.x86_64.rpm"],"source":"firefox-78.14.0-1.el7.centos.src.rpm"}]}]}

CVE

参考